2001 Dodge Ram 1500 starts but won’t idle after dead battery – FIXED!

This is a small post to record a fix that defies common sense, but worked like a charm.

I left the cab light on the the truck and when I came back to it 2 days later the battery was dead.  I recharged it, and the truck would start but wouldn’t idle.  As soon as I let off the gas the engine would cut off.  I did an initial search that didn’t help and went back out to fiddle with the truck.  Frustrated, I came back in and tried again.  I must have used different words, because this time I got some strange advice on a comment on this forum question.

If you recently had a dead battery and re charged it you need to reset your computer. To do so follow these steps: A) Disconnect the negative battery cable B) Turn Your Ignition key to Start position for 30 seconds while putting the gas to the floor. c) Clean and reconnect neg terminal (good time to also clean the Pos Terminal if needed) D) restart the engine and you will be good to go.

I was running through all the bad scenarios of replacing the alternator, etc so I figured it couldn’t hurt to try since the cost was my favorite price (free).  I did it and next thing you know the truck was running.  I took it out and drove to Home Depot (It died on the way but started up again easily) and I haven’t had trouble since.

Wow, this solution just doesn’t make sense, but it worked for me!  🙂

 

 

Advertisements

Leave a reply, would love to hear from you!

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s